Monday, December 17, 2012

hacmp basic concept

HACMP

HACMP stands for High Availability Cluster Multiprocessing

Hacmp provides two types of environment

1. serial (high availability): this is used  to make the application highlt available
by using the shared disk and duplicate resources .  also the access to data  will be serially
means one node at a time.
2. parallel (cluster multiprocessing ) : this type of environment is used when the application is
 online on many nodes  and allthe nodes  can  concurrently access the data. for this type of environment
failover is not required.




why to use hacmp?

1. eliminating single point of failure
2. elminating planned and unplanned downtime.


hacmp ensures that the application should be highly available and accessible
 even if hardware ,software or any system management failure is there.


what is single point of failure?


1. node
2. power source
3. network adapter
4. network
5. disk adapter


WHAT TYPE OF FAILURE HACMP MONITORS

1. NODE and OS failure by using the redundant nodes
2. NIC failure by using redundant NIC cards
3. protection against network failure by using redundant network.

 SHARED EXTERNAL DISK DRIVES:

A  shared external disk drive is a disk connected to multiple nodes.

HACMP supports the following type of access to shared disk.

Non-concurrent access:  only one node can access  the data at one time. it uses serial environment.
                                      if the node that is using the disk fails then failover happens
                                    and other node  becomes the active node and accesses the data.

concurrent access:  the shared disks are actively connected to more than one node and data
                              can be accesses simultaneously . in this case parellel environment is used
                              and there is no need of failover.




A  hacmp  cluster comprises of 

1. topology (nodes, NIC, network etc)
2. resources (things need to make highly available)



HACMP Topology components:

1. nodes
2. networks
3. communication devices
4. communication interfaces



what  the term node refer  in HACMP?

A node is a standalone server having hacmp software and member of the cluster.


In a HACMP cluster 32 nodes can be configured.

Network

In HACMP two types of network is defined.

1 . IP-Network
2.  Non-IP network

IP Network uses the TCP/IP protocol suite for communication between the nodes.

NON-IP network  is  used for monitoring the status of the cluster and is strongly recommended.
                                           This is because if there is network failure ,and only IP-network is used ,  it is diffcult for the active node to figure out whether it is  node or network failure  and this can lead to confusion and leads to  cluster partitioning or node isolation. .
                                            Non-ip network is used for differentiating between node and network failure.
 

Communication Interface:

In HACMP environment ,we are calling each  Network interface which is having a ip_address and an ip-label associated with it.  on the nodes which uses  IP network  for communication . we call

 en0 (network interface)
        ip-address (192.168.10.4)
       ip-label (abhi_boot1)


Communication devices:

In HACMP environment  , the devices used to configure the NON-IP  Network is called communication devices.
              it can be RS232( /dev/tty)  device , disk (/dev/hdisk#) etc

     communication devices provide point to point serial  connection normally used for heartbeating .


What does resources means in HACMP? 

 As per my understandings,  HACMP  is completely designed  for making the application  highly  availabilite.

 So the things required to make the application run on the node is considered as HACMP resources.

take and example of  application , what are the things required  for making it highly available:

1. how to control(start/stop) the application  : ( when some hardware error accurs ,resources need to move    from one node to another , then hacmp must be aware how to start and stop the application that's why we are providing start/stop script   )

2. how to access the application(to access you need ip  and can move from one node to another )
3. common storage is required(if one node is down then other can access)
4. sometime nfs is required
 

Resouces can be:

1. application server
2. service- ip
3. volume group
4. filesystem
5. NFS mounts:
6. NFS  exports

Application server : The application that has to be made highly available along with it's start/stop script is termed as application server in hacmp environment.

Service-ip/label:  every application should have an IP address assigned to access it and that ip should be highly available

volume group: if the application requires shared storage, this storage should be coming from this VG .

filesystem : filesystems required for making the application highly available

NFS mount :  NFS filesystems required for making the application highly available

NFS exports: NFS filesystem that need to be exported for running the application




What is Resource Group ?

Resource group is a collection all the resouces that are needed to make and application highly available.
                                                   
while defining resouce group ,we need to specify  polices(startup/failover/fallover)  that controls the resource group  action when  it detects  any failure.



As earlier , i have written that resource group is controlled by the policies.
the RG policies are :

1   Startup policy                     (used when cluster starts up.)
 2. Fallover policy                 (if node failure is there, it determines which node to takeover)
 3. Fallback policies               (when the higher priority node comes up, then this policy decides whether to
                                             move the RG to higher priority node or node)

startup policy:

 online on home node only :      The resource group is brought online only on its home (highest priority  
                                                   node defined ).if it is unavailable RG  will not start automatically.
available on first available node : The resource group comes online on the first participating node that  
                                                  becomes available.it's just like rotating RG.
using distribution policy :              here only one RG is active on one node. if one node is having an active RG
                                                  ,it will goto second if it is not having any active RG.
on all available nodes:                  This policy is used when you need that all nodes  can access the same RG
                                                   concurrently.


Fallover/failover policy:

Fallover to next priority node in the list :     at the time of failure,RG is moved to the next high priority node in
                                                                  the RG definition
Fallover using dynamic node priority : if using this option,  then the fallover will  happen according to the
                                                         selected criteria from the below methods
                                                                            1. highest_mem_free
                                                                            2. highext_idle_cpu
                                                                            3. lowest_disk_busy
Bring offline(on error node) : this is used with concurrent RG.since  RG is active on all nodes concurrently,
                                             if one node goes down, then RG on this node should become online for the maintenance of that node..


Fallback policy


fallback to higher priority node in the list:        when the highest priority node comes up, the RG is
                                                                     automatically moved to it.
Never fallback :                                             it will not fallback to higher priority node automatically, you
                                                                     need to move the RG manually.




--------------under construction-----------------------------------------



                                                                                                                        











Sunday, December 16, 2012

migration from aix 5.3 to 6.1

=======================================================================================
pre-migration check
=======================================================================================
Making sure your system is ready to migrate

step 1#### :            Make sure your system does not have existing installation issues before migrating.
                       
                         # mount -v cdrfs -o ro /dev/cd0 /mnt

                        copy the  pre_migration script to your system from the location  /mnt/usr/lpp/bos/pre_migration.
                      
                         # cp -r /mnt/usr/lpp/bos/pre_migration  /tmp
                         #  chmod 777 /tmp/pre_migration
                         # sh /tmp/pre_migration
                         the output of the script is saved under /home/pre_migration.<date> directory
                         # cd /home
                         # cd pre_migration.23102012
                               The pre_migration command performs the following actions: 
                                               List the device filesets being removed.
                                               List all other filesets being removed.
                                               List the saved base configuration files that will not be merged.
                                               List configuration files that will be merged.
                                               Verify fileset version consistency.
                                               Create a list of all filesets installed, to be used by the post_migration command.
                                               Check the size and location of the boot logical volume.
                                               Check the major number for rootvg is 10.
                                               Check for the missing DB directory for the bos.net.ipsec.keymgt fileset.
                                               Determine if Kerberos is being used.
                                               Check disk and memory sizes.
                                               Check the firmware level for the IBM® Power Systems™ 7025/7026 systems.

                              Note: The required version of the firmware can be obtained from the following Web site:
                                    http://techsupport.services.ibm.com/server/mdownload

------------------------------------------------------
step 2 ###  System platform check.

                           Only CHRP systems are supported in AIX 5.2 and above.
                       
                                 # lscfg | grep Architecture  

step 3 ### (Required hardware if migrating to AIX 6.1 )
                            Only 64-bit  (CHRP) are supported
                          
                                  # prtconf -c
                                   The command returns CPU Type: 32-bit or  64-bit.
                                    it should be 64-bits

step 4 ####     Verify the major number for /dev/rootvg and /dev/hd5 is 10.
                                             # ls -al /dev/rootvg
                                                The output should be similar to:
                                                crw-rw----   1 root     system       10,  0 Jan 29 09:44 /dev/rootvg

                                               # ls -al /dev/hd5
                                                 The output should be similar to:
                                                 brw-rw----   1 root     system       10,  1 Feb 22 16:00 /dev/hd5

                              *If the major number is not 10 on your system, contact your support personnel for assistance.
 step 5 ###  Check boot logical volume size.
                                finding which disk is having the boot logical volume .
                                                 # lslv -m hd5
                                                    hd5:N/A
                                                    LP   PP1  PV1
                                                   0001 0001 hdisk0
 
                              The listing under the “PV1” column indicates which disk hd5 is located.
                              Any other entries under “PV2”...etc, simply represent mirrored copies.
step 6 ####  Recreate the boot image
                                           # bosboot -ad /dev/hdisk0
                                             bosboot: Boot image is 35795 512 byte blocks.
                                           # bosboot -ad /dev/ipldevice
                                             bosboot: Boot image is 35795 512 byte blocks.
                               note:  If either of these two commands fail for any reason, please call the support center
                                      for resolution before proceeding.
                                      Finally, with the continual introduction of new devices and hardware the boot images are growing larger.
                               You will want to make sure your hd5 logical volume has enough free and contiguous space to hold the boot image.
                               Currently the recommended allocated space to have for hd5 is 32MB.
                               This is of concern in environments with smaller disk sizes, and should be checked before running an update.
                                              # lsvg -l rootvg |grep hd5
                                                 hd5 boot 1 1 1 closed/syncd N/A
                                              # lsvg rootvg |grep SIZE
                                                 VG STATE: active PP SIZE: 32 megabyte(s)
                               This information tells us that hd5 is 1 partition, and that the partition size is 32mb.
                               This should be enough to contain the boot image. Smaller partition sizes will require more partitions to be allocated.
                               Your hd5 partitions also do need to be contiguous partitions. Check this by running the following command :
                                               # lspv -M hdisk0 |grep hd5
                                                   hdisk0:1 hd5:1
                                                   hdisk0:2 hd5:2
                                                   hdisk0:3 hd5:3
                               You can see in this example that the hd5 logical volume covers the first 3 partitions on the disk and they are all contiguous.
                               If your partitions are not contiguous, or are not covered on the first partitions of the disk
                               please call the software support center for assistance with correcting this.
                               Again, you may only have 1 partition that is large enough to handle the boot image,
                               or you may have multiple smaller partitions. Either is fine.
step 6 ###   Check if Kerberos is being used.
                               This is particular to 5.2 and above,
                               because the libraries needed for Kerberos are now shared, and need to be installed separately from the Expansion pack.
                               The BOS install process will check if Kerberos is enabled, and will set the default for installing the Kerberos software
                               bundle to yes, and prompt you for the Expansion Pack (if doing a CD install).

 step 7 ####  Memory check Verify you have the minimum required memory for your target operating system level by running the following command :
                              # bootinfo -r
                                 AIX 5.2 : 128MB
                                 AIX 5.3 : 256MB
                                 AIX 6.1 : 512MB
 step 8 ######                   A list of system configuration files that will not be merged to the latest level, but will rather,
                                 be saved in /tmp/bos, will be created by the pre_migration script, and can be viewed in the Migration Confirmation Menu.
                                 The pre_migration script will generate a list of system configuration files being merged, and will
                                 save these files in /home/pre_migration.<date>/saved_configuration_files.
 step 8 ####  ‘lppchk’ commands should be run to check system consistency:
                                
                                        # lppchk -v
                                        # lppchk -c
                                        # lppchk -f
                                        # lppchk -l
(If executed, the pre_migration script will run these commands for you).
 step 8 ###  TCB
                               If Trusted Computing Base (TCB) is enabled, the ‘tcbck -n tree’ command is run and the output saved for comparison purposes
                               after the migration.
 step 9 ###  bos.net.ipsec.keymgt
                               If bos.net.ipsec.keymgt is installed, a check is made for the /etc/ipsec/inet/DB directory, and if it does not exist, it is recommended
                               you do a force install of bos.net.ipsec.keymgt at the same level as currently installed on the system. This fileset will fail to migrate
                               successfully if this directory is missing.
  step 10 ####   No migration option
                               It has been reported that on some systems, migration is not offered as an installation option as expected.
                               To help ensure migration will be an option, the system will verify that you are currently at a previous version or release of AIX.
                               To use the same method the BOS installation code uses enter the following:
                                    # lslv -m hd5
                                        hd5:N/A
                                        LP    PP1  PV1
                                        0001 0001 hdisk0
                             # /usr/lpp/bosinst/blvset -d /dev/hdisk0 -g level
                 (The output from the command above needs to match your current version and release.)
                           Another cause of not receiving a migration option could be due to the number of disks your system is presented during the bootup process.
                           The system will only scan the first 50 disks it encounters before presenting the BOS menu selection screens.
                           If it does not encounter your rootvg disk(s) during that scan your installation option may be set to "New and Complete Overwrite".
                           If this is the case select the option, "55 More Disk Options". Taking this option will allow you to scan through all disks on the system.
                           Once you've gone through all of the disks your system should recognize your rootvg drive(s). The option for "Migration" should be selected
                           for you at this time.
 step 11 ######  Required users and groups
                           Verify that these user and groups are unchanged. The /etc/passwd file should have the following entries. It is also important that the User
                           IDs (UIDs),  which is the third colon-separated field, are not duplicated for other users.
                                   root:!:0:0::/:/bin/ksh
                                   daemon:!:1:1::/etc:
                                   bin:!:2:2::/bin:
                                   sys:!:3:3::/usr/sys:
                                   adm:!:4:4::/var/adm:
                                   uucp:!:5:5::/usr/lib/uucp:
                                   guest:!:100:100::/home/guest:
                                   nobody:!:4294967294:4294967294::/:
                                   lpd:!:9:4294967294::/:
                           The /etc/group file should have these entries. It is acceptable to have more users added to a group
                           (comma separated additions to the last field as seen with group "sys" in this example).
                           As with users, the Group IDs (GID's), which is the third colon-separated field, should not be duplicated for other groups.

                                       system:!:0:root
                                       staff:!:1:
                                       bin:!:2:root,bin
                                       sys:!:3:root,bin,sys
                                       adm:!:4:bin,adm
                                       uucp:!:5:uucp
                                       mail:!:6:
                                       security:!:7:root
                                       cron:!:8:root
                                       printq:!:9:
                                       audit:!:10:root
                                       ecs:!:28:
                                       nobody:!:4294967294:nobody,lpd
                                       usr:!:100:guest
                                       perf:!:20:
                                       shutdown:!:21:
                              (Additional users and groups are fine.)
 step 12 #####  Scheduled Jobs
                              Jobs that are scheduled during the migration time should be removed or rescheduled until after migration time.
                              It is recommended that all at jobs be removed by saving off the /var/spool/cron/atjobs file,
                              and then removing /var/spool/cron/atjobs. You can verify that no jobs are scheduled by running the following command:
                                        # at -l
                                        Save the following files if you have edited them:
                                       /usr/adm/cron/at.allow
                                       /usr/adm/cron/at.deny
                                      /usr/adm/cron/cron.allow
                                      /usr/adm/cron/cron.deny

 step 13 ###   Logical volume mapping
                              Verify that your system-created file systems and logical volumes in the rootvg are as follows:

                                         # lsvg -l rootvg

                                        LV NAME TYPE LPs PPs PVs LV STATE MOUNT POINT
                                        hd5 boot 2 2 2 closed/syncd n/a
                                        hd6 paging 96 96 2 open/syncd n/a
                                        hd8 jfslog 1 1 2 open/syncd n/a
                                        hd4 jfs 3 3 2 open/syncd /
                                        hd2 jfs 156 156 2 open/syncd /usr
                                        hd9var jfs 3 3 2 open/syncd /var
                                        hd3 jfs 38 38 2 open/syncd /tmp
                                        hd1 jfs 1 1 2 open/syncd /home
                                        hd10opt jfs 11 11 2 open/syncd /opt


                              What we are verifying here is that your "LV NAME" entries and "MOUNT POINT" entries match the entries listed above.
                              A missing filesystem, or a filesystem not mounted over the proper logical volume could cause you to not receive a migration option.
                        *NOTE: The numbers for LPs, PPs and PVs will vary and are of no importance to this check.
  step 13 #####  Location code verification

                             You may want to record the location codes of your rootvg disks before the migration, as sometimes in maintenance mode the hdisk numbers
                             can be different than what they are in normal mode. The location code will always remain the same.

                                                # lsdev -Cc disk


 STep 14 ###########     Make an mksysb backup for rootvg on bootable media such as tape with verify Readable option turned on.

step 15 ###########                    • Make a copy of following files if exist.
                                            /etc/inetd.conf
                                            /etc/inittab
                                            /etc/motd
                                            /usr/dt/config/Xservers
step 16 #########      If /etc/nextboot exists, check and remove any of the restricted tunables
                       so that you pick up the correct defaults.


 step 17 ####          • Ensure root user has a primary authentication method of SYSTEM. Run following command to check this condition.
                                       # lsuser -a auth1 root
                                  Change the value if needed.
                                       # chuser auth1=SYSTEM root

step 18 #####   check the error log or have a copy of this.
                    # errpt > errpt_pre_migration.txt 

==================================================================================================================================
How to upgrade AIX from version 5.3 to version 6.1
====================================================================================================================================
This document describes updating a p505 server from AIX 5.3 to AIX 6.1
Preparation
IMPORTANT - Read the release notes for the version of AIX you are upgrading to
The release notes for AIX 6.1 can be found here --> AIX 6.1 release notes
Note - POWER3 processors are NOT supported by AIX 6.1
•Ensure you do a full system backup and ensure that you create a mksysb before upgrading AIX.
•Check if the hardware microcode is up to date - see the microcode update document on this web site.
•Ensure all hardware including external devices are connected and powered on.
•Check for any existing faults on the server using the command errpt -a and fix as required.
•Ensure that there is enough free disk space available.
•On the server you want to upgrade check what disk rootvg is installed on.
 To do this type lsvg -p rootvg. In this case I found rootvg to be installed on hdisk0. •Check that the CDROM drive is listed in the bootlist before the hard disk by typing bootlist -m normal -o
 If the CD drive is not listed before the hard disk i.e. hdisk0 cd0, then change the boot order by typing bootlist -m normal cd0 hdisk0.•It is advisable to reboot the server before updating it to ensure that if the server fails to reboot the cause can be more easily determined and not attributed to the update process.
 To reboot the server shutdown any applications and then type shutdown -Fr. •Also run lppchk -v, this will check to see if all the currently installed software is correctly entered in the Software Vital Product Database (SWVPD) and that all filesets have all the required requisites and are completely installed.
=======================================================================================================================================
Upgrading
=======================================================================================================================================
Put the AIX 6.1 base operating system CD or DVD into the CD/DVD drive
The console for this upgrade was a dumb vt100 type terminal, the display may be slightly different for a graphical display
Reboot the server type shutdown -Fr
The server should boot off the media in the CD/DVD drive and a screen should display some selectable options as follows
-----------------------------------------------------------------------------------------------------------------------
1 = SMS menu    5 = Default bootlist
8 = Open Firmware   6 = Stored bootlist
-----------------------------------------------------------------------------------------------------------------------
Ignore these for now and the installation should continue
The next screen should display
-----------------------------------------------------------------------------------------------------------------------
Starting Software
Please wait
-----------------------------------------------------------------------------------------------------------------------
Next screen
-----------------------------------------------------------------------------------------------------------------------
Please define the System Console
Type a 1 and press Enter to use this terminal as the system console
-----------------------------------------------------------------------------------------------------------------------
Type 1 and press enter
-----------------------------------------------------------------------------------------------------------------------
1. Type 1 and press Enter to have English during install
>>>choice[1]:
-----------------------------------------------------------------------------------------------------------------------
Again type 1 and press enter
-----------------------------------------------------------------------------------------------------------------------
Welcome to Base Operating System Installation and Maintenance
Type the number of your choice and press Enter. Choice is indicated by >>>
>>>1. Start Install now with Default Settings
   2. Change/show Installation Settings and Install
   3. Start Maintenance Mode for System Recovery
   4. Configure Network Disks (iSCSI)
   88 Help?
   99 Previous Menu
   Choice[1]: 2
-----------------------------------------------------------------------------------------------------------------------
Type 2 and press enter to change the installation settings
-----------------------------------------------------------------------------------------------------------------------
Installation and Settings
Either type 0 and press Enter to install with current settings
or type the number of the setting you want to change and press Enter
1. System Settings:
   Method of Installation ......................Migration
   Disk where you want to Install ..............hdisk0   
2. Primary Language Environment settings (AFTER Install):
   Cultural Conventions ........................English (United States)
   Language ....................................English (United States)
   Keyboard ....................................English (United States)
   Keyboard Type ...............................Default
3. Security Model...............................Default
4. More Options (Software install options)
>>> 0 Install with the current settings listed above
88 Help?
99 Previous Menu
>>> Choice[0]:
-----------------------------------------------------------------------------------------------------------------------
Change the "Method of Installation" to "Migration" if not already selected
Ensure that the "Disk where you want to Install" is set to the correct disk
Change the "Cultural Conventions", "Language" and "Keyboard" to your prefered location
Type 4 and press enter for "More Options (Software install options)"
-----------------------------------------------------------------------------------------------------------------------
Install Options
1. Enable System Backup to install any system....Yes
2. Import User Volume Groups.....................Yes
3. Remove Java 1.1.8 Software....................No
>>> 0 Install with the current settings listed above
88 Help?
99 Previous Menu
>>> Choice[0]:
-----------------------------------------------------------------------------------------------------------------------

Check the values for the fields are as listed above and then press enter to accept the default value of 0 "Install with the current settings listed above

-----------------------------------------------------------------------------------------------------------------------
 Migration Installation Summary
Disks: hdisk0
Cultural Convention: en_GB
Language: en_US
Keyboard: en_GB
Import User Volume Groups: Yes
Enable System Backup to install any system: Yes
Remove Java 1.1.8 Software: No
>>> 1 Continue with Install
88 Help?
99 Previous Menu
>>> Choice[1]:
-----------------------------------------------------------------------------------------------------------------------

Check the fields if all the values as correct then press enter to accept the default value 1 "Continue with Install

-----------------------------------------------------------------------------------------------------------------------
 Migration menu preparation
Please wait
Approximate   Elapsed time
% task complete   (in minutes)
-----------------------------------------------------------------------------------------------------------------------

Next screen

-----------------------------------------------------------------------------------------------------------------------
 Migration Confirmation
Either type 0 and press Enter to continue the installation
or type the number of your choice and press Enter
1. List the saved Base System Configuration files which will not be merged into the system
   These files are saved in /tmp/bos
2. List the filesets which will be removed and not replaced
3. List directories which will have all current contents removed
4. Reboot without migrating
Acceptance of license agreements is required before using system.
You will be prompted to accept after the system reboots
>>> 0 Continue with the migration
WARNING: Selected files, directories and filesets (installable options)
from the Base System will be removed.
Choose 2 or 3 for more information
88 Help?
99 Previous Menu
>>> Choice[0]:
-----------------------------------------------------------------------------------------------------------------------

Have a look at each menu option then type 0 and press enter to "Continue with the migration"

-----------------------------------------------------------------------------------------------------------------------
 Saving system configuration files in /tmp/bos
Removing obsolete filesets, directories and files
Installing Base Operating System
Please wait
Approximate   Elapsed time
% task complete   (in minutes)
-----------------------------------------------------------------------------------------------------------------------

The installation should continue and eventually finish and present a login screen

Login and check the version of AIX by typing oslevel -s

And that's it. You may want to apply the latest Technology Level and Fix Pack now. See the relevant procedure on this website.


-----------------------------------------------------------------------------------------------------------------

content of aix cd's


I have 8 volumes in my CD set. What are they for, and will I need them all ?
You will likely not need all 8 volumes of media. The install process will prompt you for the volumes it requires as the installation proceeds. Below is a brief description of each volume :
Volume 1
Contains the minimal Base Operating System (BOS) software installed on every system,
 as well as all devices and both kernels, and the English message catalogs. To install
 a system with only "Volume 1" from the BOS menu, set Desktop to NONE, change the default
 for Graphics bundle to No, and change the default for System Management Client bundle to No.
Volume 2
Contains software to install the Graphics bundle, and to set the Desktop to CDE.
System management software, X11 software and Java software are on this CD and on Volume 3.
Volume 3
Contains system management software, printer software, as well as additional CSM,
 RSCT, Fortran, and Java software.
Volume 4
Contains pieces of Open_GL, PEX_PHIGS, LDAP, and DB2® software that comes with AIX.
Volume 5
Contains software for installing AIX in other languages. Messages,
 help text, and locales for German, French, Italian and Japanese are included.
Volume 6
Contains software for installing AIX in other languages. Messages, help text,
 and locales for Catalan, Czech, Spanish, Hungarian, Polish, Brazilian Portuguese, Russian, and Slovakian are included.
Volume 7
Contains software for installing AIX in other languages. Messages, help text,
and locales for Korean, Simplified Chinese, and Traditional Chinese are included.
Volume 8
Contains software to support bidirectional and complex text languages,
including Arabic, Hebrew, Thai, Vietnamese, Hindi, Tamil, Telugu, Gujarati, Marathi, Kannada, Malayalam, Welch, Maltese, Azerbaijani-Latin, Urdu (India),
 and Urdu (Pakistan). Chinese language support for Hong Kong and Singapore is also included 

Wednesday, October 31, 2012

src issue after restarting

SRC NOT WORKING

0513-053 The System Resource Controller is experiencing problems with its socket communications

0513-001

Possible Causes



sometime while you are rebooting the system srcmstr will not start automatically .because of this lssrc command will not work . and you will be experiencing issue with the services  managed by SRC

solution:

step 1  :   goto /dev directory.
              # cd /dev

check for the below mentioned file and directory  /dev/SRC file or the /dev/.SRC-unix directory

#ls -l SRC      # this is the socket file used
#ls -ld .SRC-unix
              
              
If the /dev/SRC file or the /dev/.SRC-unix directory does not exist, reboot your system by running the shutdown -Fr command. The shutdown -Fr command automatically creates the /dev/SRC file when the system comes up


step 2:

if after rebooting also srcmstr is not working then  check the /var directory.
check whether /var/adm/SRC  directory exists .

if it exists check for the content of the directory.

This directory is having 2 files." watch_list"  and "active_list"

check for watch_list file.

#cd /var/adm/SRC
#cat watch_list

10  1   /dev/SRC

also check thhe /etc/inittab entries and /etc/rc.tcpip .if everything is fine.

if this directory doesn,t exists . then best way will  be to restore the below directory from the backup
and then restart the system using "shutdown -Fr"

ii worked for me.

after that also if you are facing issue,then better to go for restoration from the backup.



glossary


  1. /dev/.SRC-unix Specifies the location for temporary socket files.
 2.  /dev/.SRC-unix/SRCD Specifies the AF_UNIX socket file for the srcd daemon.
3.    /var/adm/SRC/active_list Contains a list of active subsystems.
Caution: The structure of this file is internal to SRC and is subject to change.


4. /var/adm/SRC/watch_list            


  


.

Friday, October 19, 2012

Setting timeout parameters for ssh session



for removing  the timeout parameter   for ssh connection

clientAliveInterval  900 : means if the session is idle for  900 seconds session  will automatcally  timeout.




step 1 : and also comment following parameter in /etc/profile

# TMOUT=40


step 2 : uncomment in /etc/ssh/sshd_config file and set the "clientAliveInterval"  parameter:

clientAliveInterval 900
# TcpKeepAlive =yes
# ClientAlivecountMax 0

step 3 : stop the ssh services and again start the ssh services.


     # stopsrc -s sshd
     # startsrc -s sshd

 NOTE:  if you are not commenting TMOUT parameter, then the session will timeout if it is idle for 40 min even if you have commented the mentioned the parameters in sshd_config file.



for setting the timeout parameter to 10 minutes  for ssh connection

step 1: comment the TMOUT parameter in /etc/profile.
step 2: set the "clientAliveInterval 600" means session will timeout if idle for 10 min.
step 3: stop ths sshd services using "stopsrc -s sshd"
step 4: start the sshd services using "startsrc -s sshd"

Sunday, October 07, 2012

vio server patch management

Step 1

  *   Download the service pack from the fix central website.
  *   Go through the   Readme and Release Notes for Virtual I/O Server 2.2 VIOS 2.2.0.10 FixPack 24
  *   Copy  the  service pack to /tmp.


                         #  scp  –r    VIOS_2.2.0.10-FP24   padmin@<server-ip>:/tmp

Step 2


*        Take the configuration  backup

*      check the  current ioslevel
                
                     $  ioslevel
                         2.1.3.0

*       take the vios-mksysb

              $ backupios-file <file-location> -mksysb

*        take the viosbr backup
                   $ viosbr -backup -file  /home/padmin/ abhi_config 

*       check the readability of viosbr image

                     $ viosbr -view -file /tmp/abhi_config_bkp.tar.gz

If everything is ok  go ahead  with the upgradation activity.

step 3

Before applying any  new package we need to commit the older ioslevel.
                 
                       $ updateios  -commit
                       There are no uncommitted updates.

step 4

start  the vio-upgrade using the command updateios.

                         $ updateios -install -accept  -dev /tmp/VIOS_2.2.0.10-FP24/


Output looks like this.....
                          
                  *******************************************************************************
                                                  installp PREVIEW:  installation will not actually occur.
                                        +-----------------------------------------------------------------------------+
                                                                  Pre-installation Verification...
                                         +-----------------------------------------------------------------------------+
                                                                  Verifying selections...done
                                                                 Verifying requisites...done
                                                                  Results...
                                                                   WARNINGS
                                                                              --------
                                                                 Problems described in this section are not likely to be the source of any
                                                                 immediate or serious failures, but further actions may be necessary or
                                                                 desired.
                                                      Already Installed
                                                 -----------------
                                                                 The following filesets which you selected are either already installed
                                                                 or effectively installed through superseding filesets.
                                                                           tpc.rte 4.1.0.97                                          # TPC Runtime Install Files
                                                                          tivoli.tsm.client.msg.ZH_TW 6.1.0.0        # TSM Client Messages - Chines...
                                                                         tivoli.tsm.client.msg.ZH_CN 6.1.0.0         # TSM Client Messages - Chines...
                                                                       tivoli.tsm.client.msg.RU_RU 6.1.0.0           # TSM Client Messages - Russian
                                                                       tivoli.tsm.client.msg.PT_BR 6.1.0.0           # TSM Client Messages - Portug...
                                                                       tivoli.tsm.client.msg.PL_PL 6.1.0.0           # TSM Client Messages - Polish
                                                                       tivoli.tsm.client.msg.KO_KR 6.1.0.0        # TSM Client Messages - Korean
                                                                       tivoli.tsm.client.msg.JA_JP 6.1.0.0         # TSM Client Messages - Japanese
                                                                        tivoli.tsm.client.msg.IT_IT 6.1.0.0         # TSM Client Messages - Italian
   


---------------------------some output truncated-----------------------------------------------------


step 5


once  patch  upgradation is complete you will get the prompt.
now check the “installation summary”. check the result field.
if it contains "success" then  no issues you have successfully upgraded the server.
Installation Summary
-----------------------------------------------------------------------------------------------------------
Name                                                 Level          Part           Event          Result
------------------------------------------------------------------------------------------------------------
bos.rte.install                                    6.1.6.1         USR         APPLY       SUCCESS
bos.rte.install                                    6.1.6.1         ROOT      APPLY       SUCCESS
vios.agent.rte                                    1.0.0.0         USR         APPLY       SUCCESS
vios.agent.rte                                    1.0.0.0         ROOT      APPLY       SUCCESS
pool.basic.rte                                    6.1.6.0         USR         APPLY       SUCCESS
pool.basic.rte                                    6.1.6.0         ROOT      APPLY       SUCCESS
xlC.aix61.rte                                     11.1.0.1       USR         APPLY       SUCCESS
tivoli.tivguid                                     1.3.3.1         USR         APPLY       SUCCESS
tivoli.tivguid                                     1.3.3.1         ROOT      APPLY       SUCCESS
sysmgt.cimserver.pegasus.rte           2.9.0.20       USR         APPLY       SUCCESS
sysmgt.cimserver.pegasus.rte           2.9.0.20       ROOT      APPLY       SUCCESS
sysmgt.cim.providers.osbase            1.2.8.20       USR         APPLY       SUCCESS
sysmgt.cim.providers.smash             1.2.8.20       USR         APPLY       SUCCESS
sysmgt.cim.providers.scc                  1.2.8.20       USR         APPLY       SUCCESS
sysmgt.cim.providers.metric             1.2.8.20       USR         APPLY       SUCCESS


step 6

now you need to shutdown  the vio  server.
before shutting down ,check whether all vio-clients are shutdown if not shutdown
all  vio-client partitions.

once done shutdown the vio-server.

                             $ shutdown -restart


step 7


*       Once the vio server is up .login to the server  and accept the license.

                                 $ license -accept

*       Check the ioslevel.
                                   $ ioslevel
                                     2.2.0.10-FP-24

That means vio- upgradation  is complete.

step 8

check the mappings  and configuration  details from the configuration backup