Wednesday, July 27, 2011

umask

umask (user mask)  is used to set permissions on files and directory created by that  particular user.


as we know 


4 -read
2 - write 
1 - execute


ex- 432 represents read permission to owner,write & execute permission for group and write permissions for others.


***for every user we can set umask value.


***by default umask value for all users in aix is 022.


***default permissions for file if umask is not set is 666
***default permission for directories if umask is not set is 777


note: setting the proper umask is must for system admin's.  as it reflects to the permissions of file and directories. suppose  u have set your umask to 000.it means that you had given  all(owner,group ,others)  permissions to access and edit the file. .




example to understand what umask does?


*********As we know that default umask is 022. create one file and directory and note down the permissions on that file and directory.  after that change the umask value. and again create another file and a directory and notice the differences in permissions.**********


suppose , i changed the umask for user abhi as 024 . 


#umask 024


user abhi created a  file "test". now the permissions on this file will be 666-024=642


#touch test


#ls -l  test
-rw- r-- -w-  1  abhi staff   ...............


if user abhi is creating directory aks the  permissions on the directory will be 777-024=753


# mkdir aks


# ls -l | grep aks
drwx r-x -wx  2  abhi staff ...............




for setting the umask value .




to view the current umask value


#umask


to change the umask value use


# chuser umask=024 abhi


or
login as abhi and run 
#umask 024

gathering system information(snap)



why we use snap command?


to gathers system configuration information and compress the informatiion in  pax  file we use snap command.  we  can then save it to disk or tape, or send it  to a remote system. This information can be used for futher troubleshooting.


about 8mb of free disk space is needed for that in /tmp




 the default directory for snap command output is /tmp/ibmsupt directory,


you should be root user to run snap command.



The" #snap -g"   command gathers general system information, including the following:


 1.    Error report
 2.    Copy of the customized ODM  database
3.     Trace file
4.     User environment
5.     Amount of physical memory and paging space
6     .Device and attribute information
7.     Security user information






 " #snap -g"  command also gathers the output of the " #lslpp -hac" command, which is required to recreate exact operating system environments and writes output to the /tmp/ibmsupt/general/lslpp.hac file. Also collects general system information and writes the output to the /tmp/ibmsupt/general/general.snap file






****to gather HACMP specific information from nodes node1 and node2 belonging to a single cluster.Output is written to the /tmp/ibmsupt/hacmp directory
 #snap -e -m node1,node2




this command gathers LVM characterstics.
#snap -L


to remove the snap command output from /tmp/ibmsupt run
#snap -r



how to read the snap report?

you have to uncompress it.

# uncompress snap.pax.Z

you will see that snap.pax.Z will be replaced by snap.pax

after that run,

#pax -rvf snap.pax

after that you can view the file and get all details.

#more snap.pax

important files and directories related to snap



/usr/sbin/snap - Contains the snap command.


/tmp/ibmsupt - Contains snap command output.


/tmp/ibmsupt/general/lslpp.hac - Contains the output of the lslpp -hac command, which is required to recreate exact operating system environments.


/tmp/ibmsupt/general/general.snap - Contains general system information that is collected with the snap -g command.


/tmp/ibmsupt/testcase - Contains the test case that demonstrates your system problem.


Saturday, July 23, 2011

how to get firmware updates

what is firmware?


firmware is also known as microcode. it is a licensed internal code that fixes problems and enables new system features as they are introduced.

the new features are supported by new firmware level.


System Microcode or firmware initializes the system hardware and controls the boot process enabling the system to boot up and operate correctly; it also provides the interface between the operating system software and the hardware.
Adapter Microcode or firmware is the operating code of the adapter; it initializes the adapter when power is applied and it controls many of the ongoing operations executed by the adapter.
Device Microcode or firmware  provides these same functions for devices such as tape drives.


 naming convention 
firmware names are given as


01SF_XXX_YYY_ZZZ


here,


XXX - is stream release level
YYY - is service pack level
ZZZ - is last disruptive SP level.




ex.  01SF235_185 represents release level is 235 and service pack is 185.


each stream release level supports new machine types or new features.




service processor contains two copies of firmware.which helps to manage and reduce the frequency of downtime for maintenance.


1. temporary
2. permanent


server firmware fixes are installed on temporary side.


copying the temporary firmware level to the permanent side is known as committing or accepting the fix.




firmware updates can be of two types


1. disuptive
2.concurrent


a disruptive upgrade requires system to be shutdown and powered off prior to activating new firmware level.


A concurrent  upgrade can be made on running system. doesn't require downtime.


when is disruptive upgrade required:


1. when release level is different
ex-SF230 AND SF235


2. SP level (YYY) and last disruptive SP level (ZZZ) are equal
 ex. SF235_180_180


3. SP level currently installed on system is lower  than the last disruptive level(ZZZ)of the new SP to be installed.
ex:  installed on the system -SF235_180_160
  to be installed  - SF235_185_160




*** An installation is concurrent if SP level is higher than the SP level(ZZZ) of the new SP to be installed.


ex  currently installed  SF235_180_160
to be installed -  SF235_165_160




getting firmware updates


goto ibm fix central page.


from there select the following options


 product group -----system p or power
product     - firmware,sdmc,hmc
 machine type and model . ---
you can see that after running "#prtconf" command in aix box.


you will get five  options


1. all firmware components
2. system firmware
3.device firmware
4. SDMC codes
5. HMC firmware.


according to urs requirement select the appropiate option.


if you are going for device firmware.






you should know which tpe of adapter is attached to urs system.


in aix box, run
#lsdev  -Cc adapter




select   device firmware





you will get three options through which you can download the updates


1. machine model
2. feature code(to get feature code run #lscfg -vpl fcs0 the customer card id no. is urs feature code)
3.select by device


here i am choosing the option by device type


four options will come
1. adapter
2. hard disk
3. media
4. others


I selected adapter here


after selecting you will get output like this,from this select the appropriate device update and download


10/100/1000 Base-TX Ethernet PCI-X Adapter
10/100 Mbps Ethernet PCI Adapter II
10/100/1000 Base-TX Ethernet PCI-X Dual Port Adapter


........................................................




aix.


while going for system firmware update 


product group -----system p or power
product     - firmware,sdmc,hmc
 machine type and model . ---
you can see that after running "#prtconf" command in aix box.


after that you will get next screen, from where select "you need guidance" this is best practise.
it will ask for your current installed lsmcode
you can find using :#lsmcode"


select the lsmcode from the drop-list


if you want to install using an hmc select the appropiate option
if your server is hmc managed select the appropiate option
then


if you want to upgrade select that


it will show some list select the recommended one  and download.








how to apply the  system firmware updates




run  diag command
 #diag


select "Tasks and Service Aids
  select Update and Manage Flash
Select Validate and Update System Firmware


If the fix file is located on your hard drive, perform the following steps:
  1. Select File System.
  2. Enter the fully qualified path name of the file with the flash update image. The file will be copied to the/var/update_flash_image directory.
  3. When finished, select Commit. The server firmware level that you selected will be installed on the temporary side.

Friday, July 22, 2011

AIX installation methods

there are three types if AIX installation methods

          1. new and complete overwrite installation
          2. migration installation
          3. preservation  installation.

new and complete overwrite installation
we use new and complete overwrite installation when -:

a.  if we have new machine
b.  when you want to completely overwrite your's rootvg
c. you want to reassign your hard disks, i.e. you want to make ur's rootvg  size
smaller.

migration installation

we use this method to upgrade AIX version 4.2 to 4.3 ,aix 5.2 to 5.3 or 6.1

the installation process determines which optimal software products must be installed.

except /tmp ,this method preserves most filesystems including rootvg, logical volumes and system configuration files.

preservation installation

we use preservation installation when you want to preserve user data in the rootvg.

this method overwrites the /usr ,/var ,/tmp  and /root filesystem.

the /etc/preserve.list"  file contains the list of system files to be copied and saved during a preservation BOS installation.
                 the" /etc/filesystems" file is listed by default.

you can add full path names of any additional files that you want to save during preservation installation to the preserve.list file.


trusted computing base(TCB)
the trusted computing base is the part of the system that is responsible for enforcing the information security policies of the system.

by installing the system with the TCB option, we can enable the trusted path,trusted shell,trusted processes and system-integrity checking.

every device is a part of TCB ,every file in /dev directry is monitored by TCB.

TCB automatically monitors over 600 addtional files ,storing ritical information about this files in the "/etc/security/sysck.cfg" file.

it is recommended to backup this file after BOS installation.

you can enable TCB only at the installation time.

TCB can be removed by removing "bos.rte.security" fileset from your system.

#usr/bin/tcbck

if this command shows usage details..then TCB  is enabled in your system.

device management

there are three commands through which you can get device information.

1.lscfg  - this command displays configuration,diagnostic and vital product data(VPD) information about the system.

2. lsdev - displays devices in the system and their characterstics.
3. lsattr - displays attribute characterstics and possible values of attributes for devices in the system.


lscfg

lscfg displays
1. part no.
2. serial no.
3. engneering changes level from either the customized VPD object class or platform specific areas.


#lscfg

displays the name ,location and description of all devices found in customized VPD object class that is child device of sys0 object.


#lscfg -v -l ent0

here -l is for logical name
-v for vital product data

#lscfg -vpl rmt0
here -p is for platform specific information.

using lscfg command we can see the location code, WWPN number and current firmware level.

#lscfg -vpl fcs0|grep network

it gives WWN number.


lsdev command

lsdev command is used to display information about the devices from the device configuration database.


there are two types of databases
1. predefined
2. customized

predefined database

all the devices that are supported by aix will be listed here.
device driver will be available for all the devices listed in predefined database. only you have to run cfgmgr to configure it.

customized database
all the devices currently available for use will be listed here.

-P option is there to search devices from predefined database
-C option is there for searching devices from customized databases

#lsdev -P -H

it list all the predefined devices

#lsdev -C -H
it displays all devices of customized database.

#lsdev -Cc adapter

it list all the available adapters

#lsdev -Cc if ---it displays all available network interfaces
#lsdev -Cc processor --list all available processors
#lsdev -Cc tape -- list all available tape drive
#lsdev -Cc disk--list all available disks

#lsdev -C -H -S a -F 'name class subclass type'
to list the name class subclass type of every device in available state in the customized database.


lsattr command


"lsattr "command displays information  about the attributes of the given device or type of device.

you have to specify one of the following flags with lsattr command

-D --displays default value
-E ---displays effective value


#lsattr -El rmt0
lists the current attributes of rmt0
#lsattr -Dl rmt0

displays default attribute of rmt0

#lsattr -El scsi0 -a bus-intr-lv1
list the current value of the attribute bus-intr-lv1 of device scsi0

#lsattr -El sys0

to display system attributes.

#lsattr -El sys0|grep realmem
to know the size of real memory

removing a device

to unload an existing device from the system ,there is two possible ways -:

1. either change the state from available to defined
2. permanently delete all items from ODM.


rmdev command is used for removing the devices


step 1  --------- it will unconfigure the cd0 while retaining its information in customized object class.

#lsdev -Cc cdrom
cd0 available

#rmdev -l cd0
defined.


2nd case  -----this will delete the device definition from the customized device object class

#lsdev -Cc cdrom
cd0

#rmdev -dl cd0
deleted



to unconfigure the scsi adapter and all its children while retaining its information in customized object class.
#rmdev -R -l scsi1
rmt0 defined
hdisk1 defined
scsi1 defined

to unconfigure the childrens of the scsi1 but not the adapter itself
#rmdev -p scsi1
rmt0 defined
hdisk1 defined

to redetect use "cfgmgr" command.


to modify existing device configuration

we use chdev command to modify the existing device parameter.


to change the retention parameter of rmt0
#chdev -l rmt0 -a ret=no

here -l for logical name
-a for attribute name

to change the maximum no. of processes allowed per user to 100
#chdev -l sys0 -a maxuproc=100

#chdev -l hdisk0 -a pv=clear
to remove the PVID from hdisk0

Tuesday, July 19, 2011

package management

Software products include those:
1. shipped with AIX
2. those purchased seperately

in AIX has these types of software components:
1. filesets
2. packages
3. licensed program products(LPP)
4. bundles

what is filesets

a fileset is a smallest installable base unit for the aix operating system.

A fileset includes all files that constitute a complete product such as bos.net.uucp or a seperatably installable part of the product such as bos.net.nfs.client.

packages?
A package is a group of seperately installable fileset that providde a set of related function.

ex. bos.net is a package

Bundles
A bundle is a list of software thatcan contain fileset,packages and LPP  that are suited for a particular use.

bundles that are used by default for the system  are  stored in
/usr/sys/inst.data/sys-bundles"

user created bundles are stored in
/usr/sys/inst.data/user-bundles"

PTF
program temporary fix is an updated fileset or a new fileset that fixes a previous system problem

PTF's are installed  using "installp" command

APAR
Authorized program analysis report is an emergency fix or interim fix to a unique problem on the system
APAR's will become PTF's after testing and verification.

APAP's are applies using "instfix" command.

                             lpp(bos)


bos.INed(package)          bos.adt(package)

                                               (filesets)
                                         bos.adt..lib   bos.adt.prof

fileset nameing convention

lpp . package  .fileset . suffix
bos . terminfo .print .data


filesets name are meaningful and describes the content of filesets

.adt - application development toolkit of LPP
.dev - device support for that LPP
.daig - diagnostic for  a fileset.
.rte - runtime or minimum set
.smit - smit tools and displays for filesets.


SOFTWARE MAINTANENCE

fileset update or update package  is a package containing modification to a existing fileset.

fileset level is referred as

version.release.modification.fix-level
ex. 5.3.0.0


changes to the version or release level require youto perform a migration installation

if you want to make changes to the modification or fix level, you will user "smit update_all"


software states

applied state
commited state

when you are installing softeare for the first time , the software will be automatically installed in committed state

when you are installing a fix or a maintainence level upgrade to a system, you will have two options either installing the software in
1. committed state 
2. applied state
when you are choosing applied state ,you will maintain two level of software.older version will bw saved in the disk and is deactivated and the newer version becomes active

applied state provides us the oppurtunity to test the newer software before committing.

if you install software in commit state, it will remove the older version.

when updated in applied state, the previous version is stored in
"/usr/lpp/pakageneme" directory

installing software
installation of software can be done in two states:
1. applied
2. committed


to install software in an applied state
#installp -a /dev/cd0
#smit installp  -----choose applied state

to install software in committed state
#installp -ac -d /dev/cd0
#smit installp ----choose committed state

Monday, July 18, 2011

user administration

There are basically three types of user groups in aix
1.system-defined user group
2.system
3. staff


system defined users are having user identifier(UID) below 200.we can't login using these users.
root user(superuser) is having UID 1 by default.
all the users that we are creating will have default  UID greater than 200.


In aix root is superuser, he can do anything .
"system "group users are also having  some administrative priviledge .ex.  it can't create user.

what is UID?
UID is called user identifier. this is unique for each user.
whenever we are creating any user,system will automatically generate a UID for that user

. you can also define yours own UID while creating.




how to create group?

for creating group use ....#smit mkgroup
for removing group ----#smit rmgroup
for changing group attributes use ....# smit chgroup


*By default when we are creating any user, UID and GID will be same.

#mkuser abhi
# ls -l /home/abhi

suppose i am creating one user abhi, by default  a  directory named"abhi" will be created in /home..
/home/abhi is our home directory. any files or directories that abhi is creating will be saved here.
                                                 while creating user we can define our own home directory also and also can change later.

creating user

for creating user "mkuser command is used.kindly assign the password also same time.

here we are creating normal user (i.e. member of staff group)
#mkuser abhi
#passwd abhi
     
after that try to run,


#ls -l /home|grep abhi

drw-rw-rw-  2  abhi staff  ......................

staff is the primary group of this user.


here we are creating admin user(i.e. member of system group)
#mkuser -a ashu
#passwd ashu          

again  try to run

#ls -l /home|grep ashu
drw-rw-rw-  2   ashu system ................

here ,system is the primary group
                                                                
you can use smit also for creating users.
#smit mkuser.

listing user attributes

for listing user attributes lsuser command is used.

#lsuser -ALL
it will list details of all the users
#lsuser abhi
it will list the attributes of user abhi

changing the attributes of user

#chuser  su=false abhi
setting the su parameter to false

#chuser shell=/bin/csh abhi
changing the login shell
#chuser home=/back/abhi abhi
changing the home directory.

you can also use
#smit chuser
removing the user account

rmuser is used to remove the user account in aix

#rmuser abhi
it will remove the user but will not remove the password attributes that are stored on passwords file

#rmuser -p abhi
it will remove user and its associated  password attributes from
/etc/passwd and /etc/security/passwd files


*  when we run mkuser command it calls "/usr/lib/security/mkuser.sys" shell script  which customizes the new user account using the parameters defined in "/usr/lib/security/mkuser.default" file.


content of  /usr/lib/security/mkuser.default


# cat /usr/lib/security/mkuser.default

user:
        pgrp = staff
        groups = staff
        shell = /usr/bin/ksh
        home = /home/$USER


admin:
        pgrp = system
        groups = system
        shell = /usr/bin/ksh
        home = /home/$USER


whenever you are creating normal user(using #mkuser ashu), it will take  user parameter from above file.and whenever you are creating user using (#mkuser -a aks)it will take admin parameter.

*****try to edit this file and change the pgrp to system in user's stanza. then you create a normal user, and notice the difference.**********


/etc/security/user-- this file contains the extended attributes of user.using this file only we are  controlling password.length,password expiry,password length.


content of /etc/security/user

#cat /etc/security/user

default:
        admin = false
        login = true
        su = true
        daemon = true
        rlogin = true
        sugroups = ALL
        admgroups =
        ttys = ALL
        auth1 = SYSTEM
        auth2 = NONE
        tpath = nosak
        umask = 022
        expires = 0
        SYSTEM = "compat"
        logintimes =
        pwdwarntime = 0
        account_locked = false
        loginretries = 0
        histexpire = 0
        histsize = 0
        minage = 0
        maxage = 0
        maxexpired = -1
        minalpha = 0
        minother = 0
        minlen = 0
        mindiff = 0
        maxrepeats = 8
        dictionlist =
        pwdchecks =
root:
        admin = true
        SYSTEM = "compat"
        registry = files
        loginretries = 0
        account_locked = false


abhi:
        admin = true
        admgroups = system
        minlen = 4
        minalpha = 1
        maxrepeats = 3

* you can set the complexity if assigning the user password by defining using smit.
minalpha=3
maxrepeat=2
minlen=6

here we are defining that our password must contain atleast 3 alphabet,we can't repeat any alphabet or number more than 2 times and our password length should be atleast of 6 characters.



/etc/passwd-- list the basic attributes of users

in password attribute field if:
* is there then, that user is invalid
if ! is there , then it is valid user

content of /etc/passwd file


# cat /etc/passwd
root:!:0:0::/:/bin/bsh
daemon:!:1:1::/etc:
bin:!:2:2::/bin:
sys:!:3:3::/usr/sys:
adm:!:4:4::/var/adm:
uucp:!:5:5::/usr/lib/uucp:
guest:!:100:100::/home/guest:
lp:*:11:11::/var/spool/lp:/bin/false
invscout:*:6:12::/var/adm/invscout:/usr/bin/ksh
snapp:*:200:13:snapp login user:/usr/sbin/snapp:/usr/sbin/snappd
ipsec:*:201:1::/etc/ipsec:/usr/bin/ksh
nuucp:*:7:5:uucp login user:/var/spool/uucppublic:/usr/sbin/uucp/uucico
ashu:!:207:1::/home/ashu:/usr/bin/ksh
abhish:!:204:1::/home/abhish:/usr/bin/ksh
ex:!:8:0::/ambar/ex:/usr/bin/ksh


/etc/security/passwd --it contains the password information of the user.
users who have invalid password(*) in /etc/passwd will not have entry in  this file.

content of /etc/security/passwd


# cd /etc/security
# cat passwd
root:
        password = 85tnC0rb2lxn.
        lastupdate = 1296302793
        flags =


daemon:
        password = *


bin:
        password = *


sys:
        password = *


adm:
        password = *


ashu:
        password =
        lastupdate = 1302130037
        flags = ADMCHG




/etc/security/login.cfg -- this file contains the details of configuration information for login and user information

content of /etc/security/login.cfg


#cat /etc/security/login.cfg
default:
        sak_enabled = false
        logintimes =
        logindisable = 0
        logininterval = 0
        loginreenable = 0
        logindelay = 0


usw:
        shells = /bin/sh,/bin/bsh,/bin/csh,/bin/ksh,/bin/tsh,/bin/ksh93,/usr/bin/sh,/usr/bin/bsh,/usr/bin/csh,/usr/bin/ksh,/usr/bin/tsh,/usr/bin/ksh93,/usr/bin/rksh,/usr/bin/rksh93,/usr/sbin/uucp/uucico,/usr/sbin/sliplogin,/usr/sbin/snappd
        maxlogins = 32767
        logintimeout = 60
        auth_type = STD_AUTH



/etc/security/limits  -- this file contains details about the process resource limits for each user.

content of /etc/security/limits





# cat /etc/security/limits
default:
        fsize = 2097151
        core = 2097151
        cpu = -1
        data = 262144
        rss = 65536
        stack = 65536
        nofiles = 2000
abhi:
        fsize = -1
        core = 2097151
        cpu = -1
        data = 262144
        rss = 65536
        stack = 65536
        nofiles = 2000



#ulimit -a 
this command reads the limits file.
#ulimit -f unlimited
changes the file size parameter to unlimited.

you can also change the parameters by directly editting the above file.
if you are setting any parameter to unlimited you edit that to -1.

etc/security/lastlog --------this file contains details about the last login attributes for the user.

/etc/group  --- contains basic attributes of the group.
/etc/security/group -- contains extended attributes of groups
$HOME/.profile ----  environment setting for that user.

/var/adm/wtmp ----  contains connect-time accounting
/etc/utmp ..  contains the record of user logged into the system. who command reads this file.




*for editting the files in /etc/security directory  we are using the "chsec" command

#chsec -f /etc/security/user  -s abhi -a su=true.

here,
-f  for file
-s for stanza
-a for attribute                                  

Sunday, July 17, 2011

access control list (acl)

step1

let us create a file "abhi" on which we want to apply acl

#pwd
/
#touch abhi

check the permissions on the files

#ls -l  abhi

step 2

first check the permissions of the file abhi
#aclget abhi

the output will be

attributes:
base permissions
owner(root): rw-
group(system): r--
others: r--
extended permissions
disabled

here through enabling the extended permissions we are allowing or restricting particulars user oo groups from accessing the file abhi

after that run the command
#aclget -o abhi.acl abhi


 this command will create one file abhi.acl  where you can define the  extended permissions. the extended permissions will override the base permissions for mentioned users and groups. .

#vi abhi.acl
attributes:
base permissions
owner(root): rw-
group(system): r--
others: r--
extended permissions
enabled

permit rwx u:ashu
deny   rw-   g:maya


step3
applying the acl on the file abhi

# aclput -i abhi.acl abhi

step4 
verifying whether acl is working or not.

#su - ashu
$ vi  /abhi

if you are able to write on the file,it means acl is successfully applied.

Thursday, July 14, 2011

backup and restore



There are three types of backup methods:

1.     . Full backup
2.      .Incremental backup
3.      .Differential backup

FULL BACKUP
All the files are backed on the media using this.

DIFFERENTIAL BACKUP
Differential backup strategy first looks for modification time of the file and compares it with
The last full backup.

Only modified files are backed up, but only if they are changed after the latest full backup.

INCREMENTAL BACKUP
Incremental backup checks the difference between the modification time and the
Last backup time.
                                If the modified time is more recent than the  last backup date
The file is backed up.


SAVEVG

Savevg command is used to backup the user-defined volume group.
It doesn’t create bootable image.
The vg must be varied on and the filesystems to be backed up should be mounted.

Examples:
#savevg –i abhivg

It takes backup of abhivg to the default tape drive(/dev/rmt0)

#savevg –mf  /dev/rmt1 abhivg
This command backs up the abhivg and also create map file along with
a new abhivg.data file on rmt1 device

#savevg –ief /dev/rmt1  abhivg
This command backs up abhivg excluding the files listed in /etc/exclude.abhivg

#savevg –f /dev/rmt0 –V abhivg
This command backs up abhivg on tape /dev/rmt0 and also verifies the readability of file header.


Important files
/image.data – contains information about the rootvg.
 The savevg  command uses this file to create a backup image
That can be used by NIM to reinstall the VG to current system
Or to the new system.

/tmp/vgdata/vgname/vgname.data-
Contains information about the user defined volume group.
Savevg uses this file to create a backup image that can be used
By restvg command to remake that user defined VG.

RESTVG
This command restores the user defined volume group .

#restvg –f /dev/rmt0 hdisk hdisk3
To restore the VG image from /dev/rmt0 onto hdisk2 hdisk3

#restvg –r –f /dev/rmt0
To recreate the VG logical volume structure without restoring any files .

#restvg –l –f /dev/rmt0
To display VG information about the VG backed on the tape /dev/rmt0


BACKUP COMMAND
Backup command creates copies of your files on the backup media.

Backup command can be used for taking backup using :

1.                              Backing files By name( we use –i flag for this)
2.                             .Backing filesystems by i-node(we use –level flag for this)

Backing up files by name

The backup command reads the standard input for the names of the files to be
Backed up.
  File types can be special file,regular files or directories.
*if –p flag is specified only files of less than 2 gb are backed.

#find /home –print|backup –I –f /dev/rmt0
To backup all the files and directories in /home


#cd /home/abhi
#find . –print |backup –ivq

To backup all the files and subdirectories in the /home/abhi using the relative path.

Backing up filesystems by inode
To backup the filesystem by i-node , specify the “-level”
And “filesystem” parameter.

·        You must first umount the filesystem before backing up by i-node.

#backup -0 –u –f /dev/rmt0
-0 means all root filesystem files are to backed .
To backup root filesystem

#backup -1 –u –f /dev/rmt0
To backup all the files in root filesystem that are modified since the last
Level 0 backup.

RESTORE COMMAND
Restore command extracts the files backed up using the backup command.

#restore –xvqf abhi.bkup  system.data
To restore system.data file into the current directory from archieve
Abhi.bkup.the archieve is also in current directory.

#restore –xvdqf /dev/rmt0 /home/abhi/aks
To restore specific directory and its content from a file-name archieve.



service pack updation in aix

 What is service pack?
A service pack contains group of programs temporary fix(ptf) for solving the issues.

these are the some  service packs for aix 5.3  ,technology level=10. the third  parameter shows the service pack level.

here we are having service pack relese 4,5,6,7.





* for technology level upgrade, download the packages that looks like this if you are having aix version 6.1 and technology level =3.





Contents of service pack
1.       Problems that has to be resolved as early as possible since customer can’t wait until the next TL release.
2.       Critical problems reported by development team.
3.       Changes made to support new hardware .

Concluding service pack
CSP is the final SP for a TL.it usually contains fixes for critical problems or security issues.

#oslevel –s

6100-02-00-00

It shows the current level including TL ,service pack level.

*Output specifies that it has aix6.1 installed with technology level – 2 and service pack level 0.

APPLYING SERVICE PACKS

Step 1--   goto  google ,type fix central. From the output select the ibm fix central .it will redirect you to fix central homepage.

 Step 2 –for power systems,
              Select  
                                 Product group – system p
                                 Product  -aix
                                  Version -6.1
                                 Fix type – fix packs
                                 refine search- service pack

If your TL is 6100-02, Then select  TL   as 6100-02-00-0846. It will show some output,

  *From that select service pack 6100-02-01-847. Kindly check for third field that should be greater than the third field of the TL you selected .

And download it.

Before applying the fix packs on your server either take mksysb backup  or do alt-disk-install.

Step3 ---now copy that fix packs into the server( let it be in /abhi).

Step 4 ---
Now apply the fix packs using

#smit update_all

Kindly take care of these options

Input device             /abhi
Preview                    yes
Commit                    no
Accept licence         yes
Extend filesystems   yes
Automatically install prerequisite software   yes

Wait until it returns ok prompt. 

Step 5

Now check using

#oslevel –s
6100-02-01-0847



Now you have applied the service packs successfully on the servers.